chenxiaolong / kernel-acpi-rev-override

Description

This repo contains the official Fedora kernel rebuilt with the CONFIG_ACPI_REV_OVERRIDE_POSSIBLE enabled. This is needed for bbswitch to work on some laptops, like the Dell XPS 15 (9560).

These packages are not officially signed by Fedora so they will not work out of the box on systems with secure boot enabled. You will have to either disable secure boot or sign /boot/vmlinuz-*.acpi_rev_override* with your MOK.

Update (20180104): 32-bit builds have been disabled to not waste Copr's resources. Laptops that require this kernel option all have 64-bit CPUs anyway.

Update (20180217): Version kernel-4.15.3-300.fc27 of the official kernel package now has CONFIG_ACPI_REV_OVERRIDE_POSSIBLE enabled. Thus, this repository is now deprecated and will not receive any more updates. The repository will be deleted at a later date.

Installation Instructions

sudo dnf update

The kernel package has .acpi_rev_override in the version to make it easy to identify in GRUB.

Active Releases

The following unofficial repositories are provided as-is by owner of this project. Contact the owner directly for bugs or issues (IE: not bugzilla).

Release Architectures Repo Download
Fedora 27 x86_64 (0)* Fedora 27 (26 downloads)

* Total number of packages downloaded in the last seven days.


Quick Enable

dnf copr enable chenxiaolong/kernel-acpi-rev-override
More info about enabling Copr repositories

Other Actions