Jwakely's Projects

jwakely/dejagnu

DejaGnu is an Expect/Tcl based framework for testing other programs. DejaGnu has several purposes: to make it easy to write tests for any program; to allow you to write tests which will be portable to any host or target where a program must be tested; and to standardize the output format of all tests (making it easier to integrate the testing into software development).
  • Centos-stream 8 : aarch64, x86_64
  • EPEL 6 : i386, x86_64
  • EPEL 7 : x86_64
  • EPEL 8 : aarch64, x86_64
  • Fedora 37 : armhfp

jwakely/akaitools

Tools for Akai S-series samplers.
  • Fedora 35 : x86_64
  • Fedora 36 : x86_64
  • Fedora 37 : x86_64
  • Fedora rawhide : x86_64

jwakely/elektroid

Elektroid is a GNU/Linux transfer application for Elektron devices. It includes the elektroid GUI application and the elektroid-cli CLI application. Elektroid has been reported to work with Model:Samples, Model:Cycles, Digitakt, Digitone and Analog Rytm MKI and MKII.
  • Centos-stream 8 : aarch64, x86_64
  • EPEL 8 : aarch64, x86_64
  • Fedora 35 : aarch64, x86_64
  • Fedora 36 : aarch64, x86_64
  • Fedora 37 : aarch64, x86_64
  • Fedora rawhide : aarch64, x86_64

jwakely/gcc-latest

GNU C and C++ compilers built from a weekly development snapshot. See https://gcc.gnu.org/bugs/ for reporting bugs in GCC, but for problems with these RPM packages please use the github issue tracker at https://github.com/jwakely/pkg-gcc-latest/issues instead. You can also contact jwakely in the #gcc IRC channel on Libera with questions about these packages. See https://jwakely.github.io/pkg-gcc-latest/ for caveats about these builds, including how to solve dynamic linking problems for libstdc++.so.
  • EPEL 7 : x86_64
  • EPEL 8 : aarch64, ppc64le, s390x, x86_64
  • EPEL 9 : aarch64, ppc64le, s390x, x86_64
  • Fedora 35 : aarch64, ppc64le, s390x, x86_64
  • Fedora 36 : aarch64, ppc64le, s390x, x86_64
  • Fedora 37 : aarch64, ppc64le, s390x, x86_64
  • Fedora rawhide : aarch64, ppc64le, s390x, x86_64
  • openSUSE Tumbleweed : x86_64

jwakely/autotools-gcc

Packages for the specific versions of GNU autotools required for GCC development. This repository has packages for autoconf-2.69 and automake 1.15.1 (as required for GCC trunk development since 2018, i.e. gcc-9) and packages for autoconf 2.64 and automake 1.11.6 (as required for gcc-8 and gcc-7 and older release branches). These packages install executables to /opt/autotools-gcc/bin or /opt/autotools-gcc8/binso they can be installed alongside the standard system versions without conflicting.
  • EPEL 7 : ppc64le, x86_64
  • EPEL 8 : x86_64
  • Fedora 35 : aarch64, x86_64
  • Fedora 36 : aarch64, x86_64
  • Fedora 37 : aarch64, x86_64
  • Fedora rawhide : aarch64, x86_64
  • openSUSE Tumbleweed : x86_64

jwakely/keepassx1

The obsolete keepassx 0.4.x version that was replaced in Fedora 23. This version is available as keepassx0 in the official Fedora repositories, so there's no reason to use this COPR.

jwakely/Boost-beta

A sandbox for testing an unreleased version of Boost and rebuilding rawhide packages against it.