domcleal/librarian-puppet

Project ID: 216

Description

Builds of librarian-puppet, a "bundler" for your puppet infrastructure.

Note that librarian-puppet 2.x requires Ruby 1.9+. To keep EL6 support, the latest builds available will be 1.x. Once the Puppet dependency is dropped, I may build it on top of RHSCL.

Installation Instructions

  1. Get the .repo file below for your OS and install it, e.g. wget -O /etc/yum.repos.d/librarian-puppet.repo http://copr-fe.cloud.fedoraproject.org/coprs/domcleal/librarian-puppet/repo/epel-6-i386/
  2. yum -y install rubygem-librarian-puppet
  3. Create a Puppetfile
  4. librarian-puppet install

Install rubygem-librarian-puppet-doc for documentation (README).

The source spec files are maintained in git using tito here: librarian-puppet-copr

Please don't bother upstream for issues with this repo. Instead, file an issue in the GitHub repo above or contact me.

Active Releases

The following unofficial repositories are provided as-is by owner of this project. Contact the owner directly for bugs or issues (IE: not bugzilla).

Release Architectures Repo Download
EPEL 6 i386 (32)*, x86_64 (38)* EPEL 6 (227 downloads)
EPEL 7 x86_64 (2103)* EPEL 7 (659 downloads)

* Total number of downloaded packages.