m4rtink/pyotherside

Description

PyOtherSide: Asynchronous Python 3 Bindings for Qt 5

A Qt 5 QML Plugin that provides access to a Python 3 interpreter from QML.

Installation Instructions

PyOtherSide: Asynchronous Python 3 Bindings for Qt 5

A Qt 5 QML Plugin that provides access to a Python 3 interpreter from QML.

Requirements:

Qt >= 5.1.0 Python >= 3.3.0

To build and install the QML plugin:

qmake make make install

To build against a specific Python version, use:

qmake PYTHON_CONFIG=python3.3-config make make install

To run the included unit tests after building, use:

./tests/tests

More information:

Project page: https://thp.io/2011/pyotherside/ Git repo: http://github.com/thp/pyotherside/ Bug tracker: https://github.com/thp/pyotherside/issues Documentation: http://pyotherside.readthedocs.org/

Active Releases

The following unofficial repositories are provided as-is by owner of this project. Contact the owner directly for bugs or issues (IE: not bugzilla).

Release Architectures Repo Download

* Total number of packages downloaded in the last seven days.