pcpa/xz5

Project ID: 3556

Description

LZMA compression utilities.

This is the latest xz, packaged with a different name, to not conflict with rhel5 and rhel6 packages. It is multithreaded, and given enough input, will use all cpus and memory, maximizing compression and decompression performance. It replaces the system xz, but does not break packages depending on xz-libs. Note that only xz5-devel conflicts, on purpose, with xz-devel, otherwise, the other packages are updates to xz.

Installation Instructions

The package is patched from upstream to not use the pipe2 syscall, not available on rhel5 and on most rhel6 systems. From the manual page: pipe2() was added to Linux in version 2.6.27; glibc support is available starting with version 2.9. To revert to the officially supported package, run:

yum downgrade xz

The package is not supported, but suggestions and bug reports can be sent to pandrade at redhat.com

Active Releases

The following unofficial repositories are provided as-is by owner of this project. Contact the owner directly for bugs or issues (IE: not bugzilla).

Release Architectures Repo Download
EPEL 6 i386 (0)*, x86_64 (0)* EPEL 6 (50 downloads)

* Total number of packages downloaded in the last seven days.