Praiskup's Projects

praiskup/distgen

Distribution-oriented templating system (generator). this is automatic git-snapshot version from master branch in github page. You probably want to use the released dg from pypi, or your distribution-default /usr/bin/dg.
  • EPEL 7 : x86_64
  • EPEL 8 : x86_64
  • EPEL 9 : x86_64
  • Fedora 39 : i386, x86_64
  • Fedora 40 : i386, x86_64
  • Fedora rawhide : i386, x86_64

praiskup/linphone

Linphone for epel7 I found it rather complicated to install Linphone on RHEL 7 (CentOS 7). Build of the latest Linphone version is quite complicated too (it would require some library bundling) so for EPEL7 I used the 3.5.2 version copied from fedora dist-git.
  • EPEL 7 : x86_64

praiskup/tar

GNU tar Several versions of GNU tar packaged with different name to be parallel-installable with system-default tar package.
  • EPEL 6 : i386, x86_64
  • EPEL 7 : x86_64

praiskup/rpm-config

This repository currently contains only the 'compat-rpm-config' package. This package contains set of "build" RPM macros to make the cross-distro build-workarounds easier. There are limited guarantees of API stability -- it lives in Copr only (for now?). If you plan use some of implemented macros in your package, contact me to discuss stabilizing (macros are so far used only by builds of praiskup's packages in copr). Note that this package should be installable into all RHEL or Fedora versions (but it is built only against Fedora Rawhide x86_64 as a noarch package).
  • EPEL 6 : i386, x86_64
  • EPEL 7 : x86_64
  • Fedora 39 : i386, x86_64
  • Fedora 40 : i386, x86_64
  • Fedora rawhide : i386, x86_64

praiskup/pybugz-draft

The pybugz-draft is testing version of pybugz project having changes not yet upstream-approved. Most important change is the configuration management upstream proposed or ability to format output of bug-listing. Note that 'pybugz-draft' package collides with system-default package 'pybugz'. Users wanting to use this repository should know what they are doing. The package is build from this git repository.
  • EPEL 6 : x86_64
  • EPEL 7 : x86_64

praiskup/autotools

Autotools in SCL Repository provides various versions of autotools for all supported Fedora distributions, Fedora Rawhide, and all supported EPEL versions (so particular package from this repository may expect EPEL repository enabled). All tools are distributed like Software Collections -- therefore they do not collide with your installed system packages. One of the key points here is that you can run the same version of the tool e.g. both on RHEL5 or Fedora Rawhide. There are currently packaged two collections: autotools-latest -- contains latest released (stable) versions of autoconf, automake, libtool, and m4 autotools-git -- bleeding edge development versions of autoconf, automake and libtool built directly from git repositories from time to time (m4 from git is not packaged yet).
  • EPEL 6 : i386, x86_64
  • EPEL 7 : x86_64
  • Fedora 39 : i386, x86_64
  • Fedora 40 : i386, x86_64
  • Fedora rawhide : i386, x86_64

praiskup/review-dist-git-client

(temporary project, will be deleted after 9 days)
Description not filled in by author. Very likely personal repository for testing purpose, which you should not use.
  • Fedora rawhide : x86_64